(投稿前に、内容をプレビューして確認できます)

センサー

  • f2k
  • 2019/12/04 (Wed) 20:31:44
iOS 13.1.3 iPad mini にて
センサープログラムをQRで読み取り、実行させましたが、
タッチは動いているのですが、
加速度など、他のセンサーは反応していません。
以前(IOSのバージョンを上げる前)は動いていたのですが、
何か解決策はありますでしょうか。

Re: センサー

  • honda
  • 2019/12/11 (Wed) 23:29:04
開発チームの本多と申します。
センサ類が使用できない件について、現象を確認いたしました。
iOS側の仕様変更の関係で、現在加速度センサやジャイロセンサなど
センサ類の機能が使用できない状態です。
対応を進めておりますので、今暫くお待ちいただければと存じます。

チャット(双方向通信)プログラム

  • ume
  • 2019/12/03 (Tue) 09:46:29
以前、相談をしたumeです。
授業用プリント完成し、無事授業もうまくいきました。
時間に余裕があったので、生徒が自然発生的に「なりすま」しごっこをしたりして、楽しく中身のある授業ができました。
ありがとうございます。

リスト内の文字の色について

  • minaty
  • 2019/11/09 (Sat) 10:59:49
いつもお世話になっております。

リスト内に表示される文字列の色を変えたいのですが、
それぞれの行ごとに文字の色の制御可能でしょうか?
文字色を指定すると、リスト内の文字列の色が
すべて変わってしまいます。

よろしくお願い致します。

Re: リスト内の文字の色について

  • minaty
  • 2019/11/12 (Tue) 22:51:06
kenemune 様

いつもお世話になっております。
承知致しました。確かに複雑になりますね。
色の変化ではなく、他の方法を試してみます。
ありがとうございました。

今後ともよろしくお願い致します。


Re: リスト内の文字の色について

  • kanemune
  • 2019/11/12 (Tue) 19:34:56
お返事が遅くなりました。
リスト内の文字の色は変えられないようになっていたと思います。

子供たちにとってマニュアル等が複雑にならないように機能を最小限に抑えている部分だったかもしれません。

無題

  • ななな
  • 2019/11/12 (Tue) 16:12:53
かめた=タートル!作る 90 左回り ペンなし 0 -150 位置。
左=ボタン!"左" "LEFT" 作る -200 -180 位置。
左:動作=「かめた!-100 0 移動する」。
右=ボタン!"右" "RIGHT" 作る 50 -180 位置。
右:動作=「かめた!100 0 移動する」。

// ****ボタン(ステップ2)
かめた:****=「タイマー!作る「自分!20 歩く」実行」。
****=ボタン!"****" "UP" 作る -50 -180 位置 100 45 大きさ。
****:動作=「かめた!作る 55 歩く "rocket.gif" 変身する ****」。

敵たち=配列!つくる。
いち=タートル!作る "ayumiAka.gif" 変身する ペンなし 90 右回り。
に=タートル!作る "ayumiAka.gif" 変身する ペンなし 90 右回り。
さん=タートル!作る "ayumiAka.gif" 変身する ペンなし 90 右回り。

いち!(-100)(200)位置。
に!(0)(200)位置。
さん!(100)(200)位置。

// 衝突定義(ステップ5)
いち:衝突=「自分!消える。いち!(自分)消す」。
に:衝突=「自分!消える。に!(自分)消す」。
さん:衝突=「自分!消える。さん!(自分)消す」。

時計=タイマー! 作る。
時計!15秒 時間。
// 終了判定(ステップ6)
制限時間=25。
カウントダウン=フィールド!作る 150 0 移動する。
終了時計=タイマー!作る 1秒 間隔(制限時間)時間。
終了時計!「|n|カウントダウン!(制限時間-n)書く」実行。

いち:衝突=「ラベル!"おめでとう!!!"作る -100 100 位置。
 終了時計!中断」。


に:衝突=「システム!再実行」。



エリア1=テキストエリア!"問.「しげし」とはどういう意味か答えよ" "①抵抗する" "②(何かが)多い" "③それほど"作る -400 190 位置。

エリア1!読むだけ。
ラベル!"①"作る -110 190 位置。
ラベル!"②"作る -10 190 位置。
ラベル!"③"作る 90 190 位置。

//問題
ラベル!"↓の問題を読み問いに答えよ"作る -400 250 位置。

メニュー1=選択メニュー!"2のステージへ" "3のステージへ"作る 200 200 位置。
ラベル1=ラベル!作る。
メニュー1:動作=「|x|   エリア1!(1)"問.「うるはし」とはどういう意味か答えよ" "①美しい" "②潤っている" "③売る" 上書き。」。

メニュー1:動作=「|x|   エリア1!(2)"問.「むげなり」とはどういう意味か答えよ" "①ひどい" "②くさそう" "③たまげたなあ" 上書き。」。





macで出来ない

  • D
  • 2019/11/09 (Sat) 14:44:43
mac用のドリトルをダウンロードし、それをアプリケーションにコピーしましたが、"開発元を検証できないため開ません。"と出てきてしまい、ドリトルが使えません。
どうしたら使えるようになりますか?

Re: macで出来ない

  • かめみ
  • 2019/11/09 (Sat) 15:45:19
こちらのサイトに書いてあることなどは試してみましたか?
https://gori.me/mac/mac-tips/104874

削除依頼「早速の対応ありがとうございます。」の記事

  • ume
  • 2019/11/07 (Thu) 09:20:49
19年11月7日に投稿した「早速の対応ありがとうございます。」の記事が、重複しているので、消してください。

マイクロビットを使ったプログラムについて
の記事の返信に入れる予定で、
うっかり、新しいを投稿で入れてしまいました。
重複するので削除ください。
ume

マイクロビットを使ったプログラムについて

  • ume
  • 2019/11/05 (Tue) 12:21:40
先日の質問ありがとうございました。授業プリントも無事でき、後は授を待つのみです。

使い方マニュアルで、ドリトルでマイクロビットを使えることを知り、マニュアルの例を使って、すぐに購入したマイクロビットを動かしました。

Q1:マイクロビットの各センサ
光センサ、温度センサ、加速度センサ、コンパスの数値を
USBの有線を通して、(無線でも良いのですが)
ドリトルが読み取り事ができますか?

Q2:その時どのようなプログラムを書けばいいですか?

ドリトルで、
x軸を経過時間にして、
y軸をマイクロビットから送られてくる数値で、
折れ線グラフを作りたいのです。
グラフの作り方は、別の資料の物を使う予定です。
その例文は、温度の数値に(例として)変数を使ってました。
そこを、マイクロビットのセンサの数値にしたいのです。

Q3:そもそも論として、マイクロビットに、ドリトルで作ったプログラムを送ることはできるが、
マイクロビットから、センサーの数値をドリトルの送ることは、想定されていないのでしょうか?

これができると、ドリトルで、簡単な計測・制御の実習まで展開できるのでありがたいです。

Re: マイクロビットを使ったプログラムについて

  • ume
  • 2019/11/07 (Thu) 09:14:36
早速の対応ありがとうございます。

サンプルプログラムの公式ページも掲載、心待ちにしておきます。
公式にサンプルがあると、敷居が低くなるので、大変助かります。
新学習指導要領で、前回質問した双方向通信と、計測制御のプログラムの対応が求められています。
マイクロビットの各種のセンサを使えると、安価に教材の用意がしやすくなります。

マイクロビットの活用は、市内の小学校でも動きがあるようです。
小学校で、タイル形式でマイクロビットを触ってくるので、中学校としては、+αを求められます。だから、マイクロビットをドリトルで制御できるとありがたいです。
そこで、ドリトルを使うことで、マイクロビットの小さな表示画面にとわわれず、ディスプレイの大きな画面で使えます。

マイクロビットを小中で協力して購入して相互に使うことで、さらに、学校の予算の負担を減らすことも視野に入ってきます。

よろしくお願いいたします。

Re: マイクロビットを使ったプログラムについて

  • Omura
  • 2019/11/06 (Wed) 19:33:32
Micro:bit+Dolittleは、計測・制御での利用をイメージして作成しており、MicroBitでの計測値をPCで確認できるようにするために、USB経由での計測値の送受信のための簡易的な機能を設けております。
(この際には「通信端子!(XX!読む)送信。」などの命令で送信ができます。)

従いましてQ1,Q3につきましては「Yes」となります。

サンプルプログラムにつきましては、公式ページの項目を追加する形でご紹介をさせていただこうかと思います。
作業には日数をいただく必要がございますので、しばしお待ちください。
アップロード後は、こちらにご連絡させていただきます

早速の対応ありがとうございます。

  • ume
  • 2019/11/07 (Thu) 09:08:48
サンプルプログラムの公式ページも掲載、心待ちにしておきます。
公式にサンプルがあると、敷居が低くなるので、大変助かります。
新学習指導要領で、前回質問した双方向通信と、計測制御のプログラムの対応が求められています。
マイクロビットの各種のセンサを使えると、安価に教材の用意がしやすくなります。

マイクロビットの活用は、市内の小学校でも動きがあるようです。
小学校で、タイル形式でマイクロビットを触ってくるので、中学校としては、+αを求められます。だから、マイクロビットをドリトルで制御できるとありがたいです。
マイクロビットを小中で協力して購入して相互に使うことで、さらに、学校の予算の負担を減らすことも視野に入ってきます。

サーバへの書き込みと読み込み

  • minaty
  • 2019/10/21 (Mon) 13:21:31
また、お世話になります。

下記のようなプログラムで、
サーバから、 ”msg” の情報を取得できると思いますが、
この ”msg” を変数で指定することは可能でしょうか?
例えば、msg1,msg2,msg3....というように
プログラムの中で、変化させたいのです。
色々試してみましたがうまくいきません。

恐縮ですが、ご教授下さい。
よろしくお願い致します。

-----------------------------------------------
タイマー!作る 1 間隔 600 回数「
  受信メッセージ=サーバー!"msg" 読む。
  受信表示!(受信メッセージ)書く
」実行。
------------------------------------------------

Re: サーバへの書き込みと読み込み

  • minaty
  • 2019/10/22 (Tue) 14:19:35
kameta 様

いつもお世話になっております。
うまくいきました。

ボタンで、PCを選んで、
特定のPCと通信ができるようにしたいと考えています。

通信するPCの番号を配列に取り込んで、
"msg"につけて変化するようにしようと思っています。

ありがとうございました。
また、よろしくお願い致します。


Re: サーバへの書き込みと読み込み

  • kameta
  • 2019/10/21 (Mon) 15:00:04
こんにちは。文字列を変数に入れることはできると思います。

(例)
m="msg1"。
受信メッセージ=サーバー!(m)読む。

次々と変えるのは少し考える必要があるかもしれません。

「受信メッセージ!=直前メッセージ」意味

  • ume
  • 2019/10/17 (Thu) 19:15:54
チャットの自動化2で、

サーバー!"localhost" 接続。
受信表示=リスト!作る 200 400 大きさ 0 200 位置。
直前メッセージ=""。
タイマー!作る 1 間隔 600 回数「
  受信メッセージ=サーバー!"msg" 読む。
  「受信メッセージ!=直前メッセージ」!なら「受信表示!(受信メッセージ)書く」実行。
  直前メッセージ=受信メッセージ。
」実行。

例文のプログラムをドリトルで実行すると、説明書通り動きますが、

「受信メッセージ!=直前メッセージ」の意味がじっくり考えてもよくわかりません。
直前と新しい受信が違うときに、新しい受信を表示するのですが、
「もし、新しい受信と直前の受信が同じなら、受信を表示する」という意味にしか見えません。
その後の文で、新しい受信内容を直前の受信内容に切り替え、次の繰り返しをすると、理解していますが、

私の理解が間違っていることは、わかっても、どう理解したらいいのかがさっぱりわかりません。
教えてください。

Re: 「受信メッセージ!=直前メッセージ」意味

  • omura
  • 2019/10/20 (Sun) 16:51:24
>『!=』
>は、ドリトル固有のプログラムの命令(記号)だと理解してよろし
>いでしょうか?

ドリトル固有の表現とは言い切れず、C言語やpythonなど、多くのプログラム言語で、分岐の条件を指定する際に「AとBが異なる」という意味で『!=』が用いられています。
ドリトルでも、条件の表現方法としてこのルールを採用しているとお考え下さい。

ご認識の通り、『!=』は、この二つの記号をあわせて「異なる」ことを表す特別な記号である認識は正しいものです。
『!=』の二文字を合わせて判断するようにしていただければと思います。


<補足>
『!=』以外の表現を利用している例としては、ExcelのIF関数等が、学校活動等では出てくるかと思います。
AとBが異なるを『<>』と表現します。これはBASICというプログラム言語を意識したものによくみられる表現方法です。

Re: 「受信メッセージ!=直前メッセージ」意味

  • ume
  • 2019/10/19 (Sat) 12:32:21
早速のお答え、ありがとうございます。

『!=』の意味が分からなかったので、

『A!=B』
は、
AとBが違うという意味だったのですね。

そう理解するしか、あのプログラムは動かないと結論に至ってましたが、確認が取れて、ありがたいです。

『=』
があるので、
『AはB同じ』
で、

『!』

『AがBの動作をする。』
『AはBである。』
という意味だと思ってました。

『!=』
は、ドリトル固有のプログラムの命令(記号)だと理解してよろしいでしょうか?
そうであれば、意味を考えることなく、機械的に理解できます。

ありがとうございます。

Re: 「受信メッセージ!=直前メッセージ」意味

  • omura
  • 2019/10/17 (Thu) 20:00:14
お悩みの処理は、
『前回と同じメッセージをサーバから取得した場合には何もせず、
前回と違うメッセージをサーバから取得した時だけ、受信表示のエリアにその内容を表示する』という箇所です。
『!=』は左右の値が異なることを示します。

ここは、この分岐処理がない時にどんな問題が起こるかから考えると考えやすいです。

まずは、該当箇所の分岐処理がない、下記のような時にどんな問題が発生するかを考えてみてください。(実際にやってみるとわかりやすいです)
---------
タイマー!作る 1 間隔 600 回数「
  受信メッセージ=サーバー!"msg" 読む。
  受信表示!(受信メッセージ)書く
」実行。
---------

■発生する問題
相手が最後に送信した文面が、受信表示のリストに1秒に1回追加されてしまう

■なぜ起こるのか
タイマーの処理の中で、以下の2つの処理を1秒間隔で連続して実施しています。

1.”msg”のキー(名前)を持つ情報を、サーバから取得する。
2.取得した内容をリスト(受信表示)へ追加する

この時、「1.」を実施してもサーバから取得したデータが消えることはありません。相手が”msg”のキー(名前)を持つ情報を新たにサーバに送ってこない限り、「1.」を実行すると同じ情報を取得することになります。

したがって、この「1.]と「2.」を繰り返している限り、同じメッセージが何度も「受信表示」のエリアに追加されることになります。
(この動作は、ぜひご自身で試して確認してみてください)

■解決方法
タイマーで繰り返し受信処理をする中で、
一つ前にサーバから取り出した情報と、今取り出した情報が同じならば、受信表示にその内容を追加しない。
一つ前にサーバから取り出した情報と、今取り出した情報が異なる時だけ、受信表示にその内容を書き込む(追加する)


***
そして、この解決方法をプログラムで表したのが、今回の分岐処理です。
直前メッセージが、一つ前に受信した情報です。
受信メッセージが、今取り出した情報です。

この二つが異なる(受信メッセージ!=直前メッセージ)時だけ、受診した内容を表示しています。

ちなみに、今取り出した情報は、次の受信処理のタイミングでは、「一つ前に受信した情報」となります。
「直前メッセージ=受信メッセージ。」の部分が、直前メッセージの更新を行っている箇所です。