(投稿前に、内容をプレビューして確認できます)

チャットの受信について

  • minaty
  • 2019/08/07 (Wed) 23:18:17
初心者です。よろしくお願い致します。
下のものは、タイマーの中に入れる決まり文句のように使われていますが、今一つ、理解できていません。
確かに実行するとうまくいくのですが、
受信メッセージと直前メッセージが同じときに書き続けるように思えるのですが、それでよいのでしょうか?
-----------------------------------------------------
「 受信メッセージ!= 直前メッセージ 」! なら 「 受信表示!(受信メッセージ)書く。」実行。
直前メッセージ=受信メッセージ。

Re: チャットの受信について

  • kameta
  • 2019/08/09 (Fri) 12:21:10
ご確認ありがとうございました。
なるほど、「!」は確かによく使われるため、目立たないかもしれません!

Re: チャットの受信について

  • minaty
  • 2019/08/08 (Thu) 21:02:39
kametaさん、ありがとうございます。
「!=」は、比較演算子だったんですね。
「!」が多く使われるので、気づきませんでした。
他の言語の経験があればよかったのですが、
お手を煩わせてしまいました。

今後ともよろしくお願い致します。

Re: チャットの受信について

  • kameta
  • 2019/08/08 (Thu) 09:07:47
こんにちは。確かにわかりにくい部分ですね。。。
「直前メッセージ」に1つ前のメッセージが入っています。
新しいメッセージと比較したときに、「!=」で「等しくない」と判定されたときに「新しいメッセージ」と判断して表示しています。
(同じメッセージのときは「!=」が成り立たないため表示しません)

ドリトル

  • aiu
  • 2019/08/02 (Fri) 06:07:03
敵を作り自動でロケットを発射させたいのですが、どうすればよろしいのでしょうか?

Re: ドリトル

  • kameta
  • 2019/08/03 (Sat) 17:08:10
aiuさん、ご確認ありがとうございます。
使っていただけそうでよかったです。

Re: ドリトル

  • aiu
  • 2019/08/03 (Sat) 16:52:52
kametaさん回答ありがとうございます。
乱数を使うとゲームっぽくなりとてもよく作れました。
本当にありがとうございます。

Re: ドリトル

  • kameta
  • 2019/08/03 (Sat) 13:23:26
このようなものはいかがでしょう。

=====
ミサイル発射=「
ミサイル=タートル!作る 90 左回り ペンなし (乱数(300))0 位置。
ミサイル:エンジン=「タイマー!作る「自分!10 歩く」実行」。
ミサイル!エンジン。
」。

タイマー!作る 1 間隔 10 回数「
!ミサイル発射。
」実行。

Re: ドリトル

  • aiu
  • 2019/08/02 (Fri) 22:03:43
どめこさん回答ありがとうございます。
ボタンで発射するのではなく、自動で発射してくれる敵を作成したいのですが、タイマーをどのように使えばいいのか困っています。

Re: ドリトル

  • どめこ
  • 2019/08/02 (Fri) 07:31:43
こちらのページが参考になるかもしれません
https://dolittle.eplang.jp/ch_shooting

マイクロビットの端子

  • うすい
  • E-mail
  • 2019/07/29 (Mon) 15:16:53
マイクロビットの[端子]オブジェクトはありますか?あるのでしたらメソッドと使いかたを知りたいです。

Re: マイクロビットの端子

  • Omura
  • 2019/07/29 (Mon) 15:34:00
開発メンバーの大村です。

端子オブジェクトはmicro:bitのP0-P2端子に対応する「端子0」,「端子1」,「端子2」のオブジェクトがあります。
(以後それぞれの端子番号をxとして、「端子x」と表記します)

■■デジタル入力■■
端子のデジタル入力値を取得する命令は「デジタル値?」です。
電圧がHighの時は1、Lowの時は0を返します。

例)端子x!デジタル値?

■■デジタル出力■■
端子にデジタル値を出力する命令は「デジタル出力」です。
Highの出力をしたい時は1、Lowの時は0を引数に設定します。

例)端子0!0 デジタル出力。


プログラム例は
sampleフォルダ内のdigitalOutput.dtlやdigitalinput.dtlを
ご参考にしていただけければとおもいます。

ドリトル

  • aiur
  • 2019/07/25 (Thu) 15:54:36
ドリトルで、かめを図形の上を歩かすことはできますか?

例えば
四角形の辺を歩く感じです。

Re: ドリトル

  • kameta
  • 2019/07/26 (Fri) 05:43:33
すでに描いてある線の上を走らせる、ライントレースのような動きをさせるのは簡単でないと思います。

りんご

  • 鍋沢ひな
  • 2019/06/28 (Fri) 11:24:03
かめた=タートル!作る。
かめた!(緑)線の色 20 線の太さ 500 歩く。
地面=かめた!図形を作る -250 -170 位置。
//操作ボタンを作る
かめた! ペンなし -500 -140 移動する。
左ボタン=ボタン!”左””LEFT”作る -60 -180 位置 60 50 大きさ。
右ボタン=ボタン!”右””RIGHT”作る 0 -180 位置 60 50 大きさ。
左ボタン:動作=「かめた!-10 0 移動する」。
右ボタン:動作=「かめた!10 0 移動する」。
//得点と衝突したときの判断を作る
出力=ラベル!作る。
出力!(0)書く。
ゲット数=0。
地面:衝突=「|相手|相手!消える。」。
かめた:衝突=「|相手|相手!消える。ゲット数=ゲット数+1。出力!(ゲット数)書く 」。
//リンゴを落とす
「時計=タイマー!作る。
時計! 3秒 時間。
かめきち=タートル!作る ペンなし ”apple.png”変身する (乱数(400)-200)(乱数(250)-50)位置。 
時計!「かめきち! 0 -25 移動する」実行。
時計!待つ。」!10 繰り返す。
//ゲーム終了
出力2=ラベル!”おしまい!”作る。
このプログラムを打ったところ する という命令が見つかりませんと出たのですかどうしてでしょう?誰か教えてください

Re: りんご

  • きつね
  • 2019/06/29 (Sat) 13:56:10
わたしのコンピュータやIpadでは
『「する」が見つからない』というエラーは出ませんでした。(ただし、ipadでは//は直しました)

ひなさんが遭遇したエラーは、
「移動する」、「変身する」の漢字部分と”する”の間に空白が入っていたり、改行が入ってしまっていたりすると起こりやすいです。

「移動する」、「変身する」の語句の部分を一旦消して、書き直してみることも試してみてください。

Re: りんご

  • kameta
  • 2019/06/28 (Fri) 21:04:37
オンライン版で実行したところ、全角のコメント「//」を半角「//」に修正すると、正しく動くようでした。プログラム自体は問題ないように見えますがいかがでしょう。
https://jsdolittle.eplang.jp/djs/

ドリトル

  • 山内ことみ
  • 2019/06/25 (Tue) 18:19:41
壁がカメ太に迫ってくらようにするにはどうすればいいですか?

Re: ドリトル

  • きつね
  • 2019/06/25 (Tue) 18:36:31
以下は図形を移動するプログラムです。
これが参考になると思います。
あとは、マニュアルをよく読んで色々試してみましょう。

--------
かめた=タートル!つくる。
「かめた!100 歩く 90 右回り」!4 繰り返す。
棒=かめた!(青) 図形を作る。
棒!200 100 位置。
時計=タイマー!作る。
時計!「棒!-20 0 移動」実行。

ゲーム

  • 小池智洋
  • 2019/06/25 (Tue) 13:07:17
ドリトルで壁よけゲームを作りたいんですけどプログラムをどなたか教えていただけませんか、よろしくお願いします

Re: ゲーム

  • kameta
  • 2019/06/25 (Tue) 16:05:18
他人がプログラムを作ることはできないので、ドリトルのサイトにあるマニュアルのサンプルなどから近いプログラムを探してみてください。

Re: Re: ゲーム

  • 小池智洋
  • 2019/06/25 (Tue) 15:57:40
壁が迫ってくるようにするにはどうすればできるんですか?

Re: ゲーム

  • kameta
  • 2019/06/25 (Tue) 15:30:38
6/23の迷路のプログラムが参考になると思います。
http://dolittle.bbs.fc2.com/?act=reply&tid=16810368

迷路

  • はじめ
  • 2019/06/23 (Sun) 16:28:21
ドリトルの迷路のゲームの作り方のプログラムを教えてください

Re: 迷路

  • kameta
  • 2019/06/23 (Sun) 19:11:06
先ほどのサンプルでは、壁(迷路)の図形に衝突したら「残念!」と表示をしてプログラムを終わりにしています。

同じように、長方形など適当な形の図形を置いて、そこに衝突したら「成功!」と表示をするとよいように思いました。

Re: Re: 迷路

  • はじめ
  • 2019/06/23 (Sun) 18:59:26
気を悪くさせてしまったらすみませんでした、最後ひとつだけ教えてください、ゴール地点に宝を置いてそれに触ったらゲームクリアという形にするにはどうすればよろしいのでしょうか?

Re: 迷路

  • kameta
  • 2019/06/23 (Sun) 18:29:29
理解するのが難しいようでしたら、先ほどのサンプルを使わずに、ご自分でゼロから書いてみるのがよいと思います。

Re: Re: 迷路

  • はじめ
  • 2019/06/23 (Sun) 18:26:21
いろいろやってみたのですが、プログラムをいじるとカメ太が違う方向に行ってしまいます

Re: 迷路

  • kameta
  • 2019/06/23 (Sun) 18:20:26
先ほどのプログラムを読んで、どこを直せばよいか考えてみてください。

プログラム

  • ひかる
  • 2019/06/23 (Sun) 18:41:25
ブロック崩しゲームを作りたいんですけどプログラム教えてください。

Re: プログラム

  • きつね
  • 2019/06/23 (Sun) 19:06:38
本日投稿された『プログラム』のスレッドを確認するべきかな。
同じ投稿のようですよ。

ドリトル

  • 高1
  • 2019/06/23 (Sun) 18:43:42
通路を作りたいんですけど、どうすれば良いでしょうか?

Re: ドリトル

  • きつね
  • 2019/06/23 (Sun) 19:03:56
本日の『迷路』の説明がとても参考になると思います。
マニュアルの『はじめてのプログラミング』も読む必要があるかな。
確認してみましょう。そして考えよう!